欢迎来到 DPDK交流社区 ,有什么问题可以尽管在这里提问,您将会收到社区其他成员的回答;也可以将您的总结写在这里,为社区其他成员提供帮助。 QQ交流2群:635461501

centos 6.6 部署dpdk环境

+1 投票
诸位大神好, 想在centos 6.6 系统下部署dpdk环境, 当前内核版本是 2.6.32.504. 请教下大家, centos 6.6 系统通过升级内核版本, 升级gcc版本, 升级binutils版本, 以及其他相关工具或库, 可行吗? 因为我尝试了两次都失败了. 尝试升级内核版本为2.6.38.8. gcc 升级至4.8.5, binutils升级至2.22.

centos 6和centos 7的环境差别还是挺大的, 直接在centos7上部署dpdk环境很简单, 但业务重依赖于centos6.6. dpdk官方文档说, 内核版本2.6.34以上都可以, 所以请教下各位大大, 请不吝赐教.
最新提问 8月 10, 2016 分类:DPDK初学入门 | 用户: Terry.Wei (810 分)

2 个回答

+1 投票
要具体情况具体分析。

可以加入QQ群交流:127163755

群里有同学遇到过相关的问题。
最新回答 8月 12, 2016 用户: sysight (12,940 分)
嗯, 可是群里那个人貌似也没解决, 后来升级cenots7了 .. 不知道我是不是就是那个同学, 哈哈.
哈哈,有可能啊~~~~~~
+1 投票
升级一下内核,应该就可以了,dpdk对centos6和7,依赖的差别就在内核上,centos6的内核上insmod不了rte_igb.ko, 其他的应该没有什么差别
最新回答 8月 31, 2016 用户: lvenyong (340 分)
尝试通过源码编译升级内核, 两次, 结果都失败了. 捂脸逃.
...